Considering the latest rash of spam images plaguing the platform, I decided to figure out how to block embeds entirely since I never really liked them in the first place and am sharing what I got working since I figured it might be something others would like to enable themselves. (Fyi, this method requires uBlock Origin)

  • Open your uBlock settings and navigate to the ‘My Filters’ section
  • At the bottom of the document, add two breaks and then paste this: > span
  • If your instance is different than, then replace that with the instance you use to have it work.

With that enabled, images and videos shouldn’t load in comments anymore. I’m sure there’s a better way to do this, so feel free to share if you know! This is just what I knew how to get work asap. Hope it helps some people!

*0.19 seems to have borked the method I previously posted, but I was able to find another string that works that seems to be more efficient anyhow. Hopefully this one works for a while! I’m going to leave the old strings at the bottom here just to cover all bases. To reiterate, these are the old strings that, afik, do NOT work anymore. > .md-div > p > [src] > .md-div > p > video