!ozoned@lemmy.world

  • 21 Posts
  • 238 Comments
Joined 1 year ago
cake
Cake day: June 2nd, 2023

help-circle
  • !ozoned@lemmy.world@beehaw.orgtoLinux@lemmy.mlD-Bus overview
    link
    fedilink
    English
    arrow-up
    8
    ·
    7 months ago

    This is an amazing article for folks interested in the low level IPC dbus. systemd, network manager, and or applications are leveraging dbus and with the new dbusbroker I expect more and more applications leverage it. It’s MASSIVELY confusing at first, but this is such a great article I hope it helps anyone interested in thr low level communications of userspace level linux applications.


  • It’s a fair point, but I don’t think I’m worthy, hence why I asked. Lol

    i’m on beehaw and they don’t just create communities, hence why I asked here. Seems like I’m getting a number if uovotes, so not sure if others are interested in my question or woukd like to see folks posting when they go live here. Any and all thoughts are appreciated.

    Obviously wondering mod and communities thoughts as well. This is all of our space imo.













  • Your /etc/resolv.conf is generated by your NetworkManager, which you know. Seeing the settings of NM can be confusing, and I had to try to remind myself. You can manually set these in NM or as someone else stated, systemd-resolved might be doing this as well. If you’re changing this inside of NM and you’re still seeing that, then something is changing it, again systemd-resolved is the most likely culprit but there are other applications that do DNS caching such as unbound, dnsmasq, etc.

    You can try seeing NM with the nmcli command such as the following:

    $ nmcli connection show Wired\ connection\ 1

    Note that “Wired\ connection\ 1” is the name of my connection, but yours might vary. If you hit TAB though a few times it should give you options.

    You’d then look for an option like ipv6.dns and if it’s not set you’ll see “–”.

    However that “nameserver ::1” is just indicating the ipv6 loopback so on an ipv6 address your NM is saying look for something listening locally.

    If you don’t like looking at nmcli you could also check nm-connection-editor command:

    $ nm-connection-editor

    And that opens a GUI for editting connections.

    There’s also nmtui for NM’s terminal user interface.