Professional software engineer, musician, gamer, amateur historian, stoic, democratic socialist

  • 9 Posts
  • 351 Comments
Joined 1 year ago
cake
Cake day: July 2nd, 2023

help-circle





  • There’s also the Wayblue family of Wayland distros, based on Ublue.

    It’s hard to say for certain whether a distro will work for your hardware, even the Nvidia-specific images can have bugs related to the Nvidia drivers or their interaction with compositors.

    I’ve used NixOS for a year.

    I also tried Fedora Sway Atomic for a week or so. It mostly worked well, but I eventually found that it’s really hard to use Nix for development on a graphics application, because linking with the system Vulkan drivers is near impossible. The loader used by Nix’s glibc will ignore FHS locations. That seems to rule out a lot of the benefits of using Nix.

    So I gave up on using Nix + Fedora as a failed experiment and went back to NixOS.

    My wish list for Nix, Wayland, and Sway is pretty long. I kinda wish I had the time to make a new distro.


  • I just don’t support dogmatic thinking and indoctrination, especially when it creeps into politics, which is inevitable at the scale of the most popular religions.

    In theory I have no problem with other people’s faith, but in practice it degrades the critical thinking capacity of our population and, paradoxically, the moral capacity as well. That’s a net negative in my opinion.

    Charities exist without religion. I think religions often teach good moral frameworks, though very traditional. But those come with a huge caveat that you cut out a big hole in your brain for the belief that God exists and cares about how you behave. That one idea leads to so much trouble, from false prophets to normalized misogyny and hatred of gay people.











  • So right off the bat I tried rebasing from Fedora Sway Atomic to the Wayblue sway-nvidia image, but I got the error:

    Package 'rpmfusion-nonfree-release-40-1.noarch' is already in the base
    

    I think because I had previously tried installing nvidia drivers from RPM Fusion. So I reset back to the base image with:

    rpm-ostree reset --overlays
    

    After that everything went smoothly and I’m apparently booted with a functional Nvidia driver. Thanks for the help! I’m off to try running some graphics.