Hello, I’m facing some rather annoying issues with running KDE6 on Wayland. Despite consulting the Arch Wiki and various online resources, I haven’t been able to get it working. X11 works fine, so I’ve been sticking with X exclusively due to my limited experience with desktop Linux and troubleshooting.

For context, my setup includes an AMD 7950x with Unraid as the main OS. My daily desktop runs on a mainline Arch VM with an RTX 3070ti and a dedicated USB controller card passed through. This setup has been stable for months, serving my gaming and media needs.

When attempting a Wayland session, I select it, observe a brief black screen flash, and then return to the login prompt. This issue persisted through upgrades and tests on different distributions like Manjaro and Endeavor. I’ve also tried multiple Wayland compositors, all with the same outcome.

The only success I’ve had with Wayland was on Garuda, which defaults to Wayland. I’m keen on using Wayland due to its evolving features, especially since it’s essential for running Waydroid.

Any assistance would be greatly appreciated. While my use case may be unique, Waydroid is crucial for specific Android apps vital to my workflow.

Thanks in advance!

  • Markus@hubzilla.markusgarlichs.de
    3 months ago

    This should work for all Nvidia user working with Plasma6 on Arch, Garuda etc:

    Edit /etc/mkinitcpio.conf


    Change the Line and add the Nvidia Modules:

    MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

    Save the File and create the initramfs:

    sudo mkinitcpio -P

    Now Add the Kernelflags to Grub: nano /etc/default/grub

    There is a line like this:

    GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"

    add this to the line:

    GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet nvidia_drm.modeset=1"

    Now generate the new Grub config:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Reboot and have fun with wayland. Maybe you have to install: xorg-xwayland

    • cammelspit@lemm.eeOP
      3 months ago

      Sorry it took me so long to test this all out, thanks a bunch, this seems to have solved the issue. I guess I did indeed miss a step. There are certainly some weird bugs I’m getting right now with flickery apps and such but that’s sorta what I expected. HDR even works which is very nice to see. Regardless, I appreciate you taking the time to assist me here, I will have a play around and get my Waydroid config all sorted now.

      Thank you!