boo

  • 31 Posts
  • 66 Comments
Joined 5 months ago
cake
Cake day: February 7th, 2024

help-circle

  • The only times I’ve encountered a game or program not launching via Bottles, it had to do with missing dependencies and/or other issues with the installer.

    SteamDB has a list of dependencies that are used for Ape Out, of which you can try adding to your Bottle.

    However, I would try running the game in Lutris; In Lutris, if you encounter issues with the game, you can click on “show logs” which will (hopefully) help you out a great deal. Lutris uses their own runtime which is primarily pulled from Valve’s Steam runtime (IIRC), saving you from having to hunt for dependencies (if missing dependencies are the issue).


  • mudle@lemmy.mlMtoLinux Gaming@lemmy.mlBottles not working
    link
    fedilink
    arrow-up
    3
    ·
    edit-2
    9 days ago

    You can check if it’s using the Discrete GPU by going into “Details” in your game’s bottle, then go into “settings”, and make sure that the toggle for “Discrete Graphics” is turned on. You can also set an environment variable; DRI_PRIME=1. Also might want to check your HDMI or DP cable is plugged into your GPU. You could also try checking GPU usage while the game is running, and seeing if it’s using your GPU at all.

    You said you moved to Fedora from Pop_OS; If you are using an Nvidia GPU, you might want to check if you’ve got the Nvidia Proprietary drivers installed or the Nouveau drivers. You can check this by running lsmod | grep nvidia in a terminal. If you get any output whatsoever then you’re using the Nvidia Proprietary drivers, which is what you want for gaming.

    If it is a shader issue; in the same “settings” in bottles make sure DXVK and VKD3D aren’t disabled. There’s no real way to bypass shader compiling. All your games need to compile shaders.



  • mudle@lemmy.mlMtoLinux Gaming@lemmy.mlBottles not working
    link
    fedilink
    arrow-up
    7
    ·
    edit-2
    9 days ago

    Assuming when you created the bottle, you chose “gaming”, it will use “soda” as it’s default runner, which is based off of proton. Maybe try going into preferences, runners, then click on “Soda”, and try messing around with different versions.

    According to the latest ProtonDB reports of Ape Out, Proton 8.0-5 was being used. Looking at my available “Soda” runners in bottles, I see soda-8.0-2,soda-9.0-1, and soda-experimental_8.0 as the latest runners available. I would try using those runners as a start.

    Also, (I only now just noticed it), under preferences, in General, there is an “Integrations” section. Under that there’s “Steam Proton Prefixes”, which (I assume) allows you to use Proton prefixes.

    Here are the following commands, depending on your installation method of Steam to give permissions to Steam’s path if it doesn’t have it already.

    Steam non-Flatpak:

    flatpak override --user com.usebottles.bottles --filesystem=xdg-data/Steam

    Steam Flatpak:

    flatpak override --user com.usebottles.bottles --filesystem=~/.var/app/com.valvesoftware.Steam/data/Steam

    Alternatively you can use Flatseal and add the path: ~/.var/app/com.valvesoftware.Steam/data/Steam

















  • For those curious about the “Memory on Package”; this isn’t soldered on RAM. The RAM is integrated into the CPU package itself. This can be a good thing; improved performance and power efficiency, increased memory bandwidth which allows the CPU to talk to the RAM at insane speeds due to how close the RAM and CPU are to each other . The downside to all of this, is you can’t upgrade the RAM. Intel’s probably gonna pull an Apple, and charge you an insane amount for more RAM. Also, currently they only support memory capacities of 16GB and 32GB.




















  • Since you have Nvidia you’ll want to use the Nvidia proprietary drivers for the best performance. The open source driver for Nvidia (nouveau) is awful when it comes to gaming performance, unfortunately. (Although this will soon be fixed with NVK)

    Depending on your distro of choice, you’ll need to figure out whether you want Secure Boot on or not. I believe Windows 10 doesn’t require Secure Boot to be enabled, but I think Windows 11 does. So depending on how frequent you want to be booting into Windows this might be a bit of an annoyance. You can leave Secure Boot disabled and use the Nvidia Proprietary drivers as-is, but if you want to enable Secure Boot you’ll have to sign the Kernel yourself - it’s a pretty straight forward process.

    I recommend you try to keep Secure Boot enabled for the added benefit of security and ease of use when dual-booting, but if you don’t want to go through the hassle of signing your own Kernel, then simply leaving Secure Boot disabled when in Linux will suffice.

    I recommend against using Ubuntu because of Canonical’s many poor decisions with Ubuntu. I won’t get into it right now, but if you’re comfortable with Ubuntu don’t let me stop you from using it.

    In reality, you can use whatever distro you want. One distro isn’t inherently better at gaming then another. It’s a matter of configuration.