Hi everyone

I’m fighting with a network issue, where my synology nas doesn’t accept any connection from outside it’s subnet.

So, here’s my setup:

  • Unifi Infrastructure with three separated subnets:

    • default: xxx.xxx.2.0/24 - no vlan - pool with all “safe” devices (notebooks, mobiles, servers etc.)
    • IoT: xxx.xxx.83.0/24 - vlan 83 - here are all the IoT devices, including nvidia shield, multiple chromecast music devices etc.)
    • guest: xxx.xxx.20.0/20 - vlan 20 - quarantined guest wlan
    • dns server are locally hosted at xxx.xxx.2.42 and 43
  • my I got a new NAS and i designated my old DS214play (running DSM 7.1.1-42962 Update 6) as a Mediaserver that gets to live in the IoT net:

    • changed the ip from xxx.xxx.2.50 to xxx.xxx.83.50
    • updated the gateway and subnet
    • added the vlan tag 83 on the network port
    • updated the firewall to allow all necessary ports from and to the default network (so I can stream plex to my notebooks etc.)
  • The Firewall on the NAS is not activated

Issue:

  • My NAS doesn’t accept any outside connections after moving it to the IoT subnet, neither from my default network nor the internet.

What I tried:

  • allowed full access between LAN and IoT subnet for the NAS.
  • tried it with another port -> same issue
  • connected another device to this port (and setup the same firewall rules) -> this one works fine.
  • checked the unifi firewall logs --> requests get sent from the nas and answers from the other device
  • checked logs of other devices (DNS, NetCat etc.) --> they receive the requests outside of the subnet, and return their anser but the NAS seems to block/ignore any incoming packages.

What I didn’t try:

  • setting the VLAN id under "Network Interface" > "LAN" > "Enable VLAN(802.1Q)" since, as far as I understand, the Unifi VLAN implementation terminates the VLAN tag at the port of the switch (and all other devices work without specifying it locally)
  • fully reset the NAS

I’m completely stuck how to solve the issue, so I have moved the NAS back to the default net, but some use cases are not working properly that way, so I’d really like to move it to the IoT subnet. Does anybody have (has?) any hints or knows of some obscure settings which need to be updated? I’d be really grateful for any pointers.

  • towerful@programming.dev
    link
    fedilink
    English
    arrow-up
    1
    ·
    edit-2
    2 months ago

    Surely you want to enable 802.1q? Like, that is vlan aware switching and routing. Or is that on the nas?

    Edit:
    Some troubleshooting:

    Connect a laptop into the same subnet as your Nas (so same vlan and IP range/subnet) and connect to the nas. This either eliminates the NAS or the router from the equation

    • tuhrielOP
      link
      fedilink
      English
      arrow-up
      1
      ·
      2 months ago

      I’m a bit hesitant to activate the tag in the DSM, as it states that it then needs a tagged counterpart to be reachable, and since all the other devices in this subnet aren’t tagged anymore (as the switch untags the vlan at the port)

      Connect a laptop into the same subnet as your Nas (so same vlan and IP range/subnet) and connect to the nas. This either eliminates the NAS or the router from the equation

      did that, the NAS is easily reachable from within the subnet it’s only a problem from another subnet