I don’t know why but every now and then my display completely freezes, completely except my mouse which is still able to navigate the screen, but can’t interact with anything. No hotkey works, seems that the keyboard freezes too when this happens, except for the one that lets me enable the leds of the pc. I use a msi laptop with hybrid graphics card if that can help

      • DrRatso@lemmy.world
        link
        fedilink
        arrow-up
        1
        ·
        11 months ago

        I had problems with 535-104, couldn’t launch into Hyprland, tried a quick install of Plasma (though with hypr XDG) and that was laggy as all hell. Dropped back to 535-98 and it runs smooth again.

  • SkipperWannabe@lemm.ee
    link
    fedilink
    arrow-up
    2
    ·
    11 months ago

    I used to get these random freezes where mouse movements are still possible, but everything else seems to freeze. Haven’t got any recently and it occured very rarely.

    However, if I switch to another tty, using ctr + alt + f key and then switch back to the original tty, it seems to fix itself. It might not be related, but worth trying it out.

    • Gush@lemmy.mlOP
      link
      fedilink
      arrow-up
      1
      ·
      edit-2
      11 months ago

      It’s not that rare for me, it happens at least one time a boot

  • stepanzak@iusearchlinux.fyi
    link
    fedilink
    arrow-up
    1
    ·
    10 months ago

    Similar thing sometimes happens to me on my ThinkPad. I have KDE Plasma and X11 (will switch to Wayland when Plasma 6 is out). Also, sometimes the exact opposite thing happens, when my mouse is frozen, but I can interact with my system using keyboard (switching wirtual desktops and windows, typing and executing commands in terminal,…) and it all works except the mouse. It’s pretty rare, however. It happened few times after waking up from hibernation or sleep, but it happend even without that. Good luck with finding solution, maybe switching to Wayland will help if you’reon X11 like me.

    • Gush@lemmy.mlOP
      link
      fedilink
      arrow-up
      2
      ·
      10 months ago

      If i switch to wayland my hybrid graphics card won’t work and i can’t play games like i normally would on X11. Btw the solution was switching distro, as usual. Every time there’s something fucked up i just switch distro.

  • fartsparkles@sh.itjust.works
    link
    fedilink
    arrow-up
    1
    ·
    11 months ago

    Windowing system? Desktop environment? Errors / warnings in Journald/logfiles? You need to provide a fair bit more info than you have already given Arch, by default, doesn’t have a mouse-driven interface…

    Have you switched into a tty and updated relevant packages to be sure it’s not just a known bug that is already fixed?

    • Gush@lemmy.mlOP
      link
      fedilink
      arrow-up
      1
      ·
      edit-2
      11 months ago

      Wm: bspwm

      De: Cinnamon

      Do you want me to send the output of journalctl ?

      I’ve already update packages through tty but i don’t think it changed something