Ive opened user.js and set browser.startup.page to 3. according to the gui that should resume previous session (0=blank, 1=home, 2=last visited page, 3=resume previous session)

It does say, however, that “Session Restore is cleared with history (2811), and not used in Private Browsing mode”, so I set user_pref(“privacy.clearOnShutdown.sessions”, false); // [DEFAULT: true] to false, but still it opens to a new tab.

other issues: ff opens windowed, and Enhanced Tracking Protection settings dont save (I changed it to block all cross site cookies)

help appreciated :)

  • temeela [she/them]@lemmy.blahaj.zone
    link
    fedilink
    arrow-up
    0
    ·
    10 months ago

    As per the arkenfox wiki, you should not touch user.js but rather in user-overrides.js add (or create it) the following:

    /* override recipe: enable session restore ***/ user_pref("browser.startup.page", 3); // 0102 // user_pref("browser.privatebrowsing.autostart", false); // 0110 required if you had it set as true // user_pref("browser.sessionstore.privacy_level", 0); // 1003 optional to restore cookies/formdata user_pref("privacy.clearOnShutdown.history", false); // 2811 // user_pref("privacy.cpd.history", false); // 2820 optional to match when you use Ctrl-Shift-Del
    

    See info on overrides and the recipe to enable session restore