I find it incredibly disruptive every time this page comes up and it’s never completely capable of restoring my tabs. Is there any way to disable it so that it will instead update when I choose to restart Firefox?

  • Pyrarrows@lemmy.world
    link
    fedilink
    arrow-up
    117
    arrow-down
    2
    ·
    2 months ago

    When this happens, Firefox has been updated in the background & the non-updated parts that’re loaded into memory attempted to load one of the updated parts & found that they were no longer compatible, causing this message to appear.

    At this point you HAVE to restart Firefox in order to be able to use it, no way around it. Soooo very fun on Mac & Linux since both can update in the background. It’s also possible to have this happen on Windows, but it’s far more rare as it seems to require having multiple different instances running at once.

    • sugar_in_your_tea@sh.itjust.works
      link
      fedilink
      arrow-up
      40
      ·
      edit-2
      2 months ago

      On Linux at least, if you install through the package manager, it’ll only update when you update the rest of your packages. And you can be completely in control of when that happens.

      On my work Mac, I just update manually. The menu icon tells me when a new version is available, so I update within a day or two of that popping up.

      • Revan343@lemmy.ca
        link
        fedilink
        arrow-up
        10
        arrow-down
        1
        ·
        2 months ago

        On Linux at least, if you install through the package manager, it’ll only update when you update the rest of your packages. And you can be completely in control of when that happens.

        Except on Ubuntu. Also, fuck snaps

          • Revan343@lemmy.ca
            link
            fedilink
            arrow-up
            4
            ·
            2 months ago

            Ubuntu installs the snap version by default whether you’re using the GUI software manager or apt.

            I use Mint instead nowadays

            • Carighan Maconar@lemmy.world
              link
              fedilink
              arrow-up
              2
              ·
              2 months ago

              Damn, computers have gotten really far if nowadays we’re happily throwing away the performance of dockerizing ˜everything on entirely normal application installs. Sigh.

      • ReakDuck@lemmy.ml
        link
        fedilink
        arrow-up
        2
        ·
        edit-2
        2 months ago

        Sucks when the company I work in uses Kubuntu.

        I could disable this feature easily. But idk…

        Additionally something to keep in mind: Better than Windows in every aspect. I would still use Kubuntu. Its fine.

    • taladar@sh.itjust.works
      link
      fedilink
      arrow-up
      18
      arrow-down
      1
      ·
      2 months ago

      Probably doesn’t happen as much on Windows because Windows has issues replacing files that are open.

  • Dendr0@fedia.io
    link
    fedilink
    arrow-up
    43
    arrow-down
    1
    ·
    2 months ago

    Hamburger menu -> Settings -> General -> “Firefox Updates” -> “check for updates but let you choose to install them”

    As for losing open tabs, there’re a few different extensions that’ll allow you to bookmark all open tabs and throw 'em in a folder. Easy enough to do that before updating, then just delete the folder that’s created via the bookmarks manager once you’ve updated/reopened tabs.

    • NakamuraEmi_bias@lemmy.world
      link
      fedilink
      English
      arrow-up
      17
      arrow-down
      1
      ·
      2 months ago

      be warned, it’ll give you unearned optimism about how responsible you are to revisit the tabs you saved but will never see the light of day again.

      Source: someone who’s disappointed in themselves

      • variants@possumpat.io
        link
        fedilink
        English
        arrow-up
        9
        ·
        2 months ago

        I got bookmarks going back a decade, sometimes I try to visit a random one and find that it no longer exists and I don’t remember what it was or why I saved it

    • lilja@lemmy.mlOP
      link
      fedilink
      arrow-up
      3
      arrow-down
      3
      ·
      2 months ago

      When you mentioned it I remembered that of course there is a setting for this… but when I went to check it just says “Updates disabled by your organisation” In this case it’s a work laptop that has a bunch of “security” things installed on it which prevent me from doing things like …installing applications I need to do my job. Not sure how Firefox is able to update when it’s been explicitly disabled, but I will at least change this setting on my personal computer.

      • MrOtherGuy@lemmy.world
        link
        fedilink
        arrow-up
        8
        arrow-down
        1
        ·
        2 months ago

        In that case the issue is likely that files on disk are being modified by whatever mechanism your IT uses to push updates to devices. If the program files are modified while Firefox is running then you will unavoidably get this prompt.

        I suppose the best you can do is to ask your IT folks to not update programs that are currently running.

      • terrrmus@beehaw.org
        link
        fedilink
        English
        arrow-up
        2
        ·
        2 months ago

        You can also go to the Menu > History > Restore recently closed tabs

        Or something similar to that.

    • prembil@lemmy.world
      link
      fedilink
      arrow-up
      1
      arrow-down
      2
      ·
      2 months ago

      Never seen anyone using the phrase Hamburger menu. I’ll be using it now onwards. Thank you random lemmy user!

  • Nakedmole@lemmy.world
    link
    fedilink
    arrow-up
    17
    arrow-down
    2
    ·
    2 months ago

    I have been using Firefox as my only browser for many, many years now and I have never seen that message before.

        • 30p87@feddit.de
          link
          fedilink
          arrow-up
          8
          arrow-down
          7
          ·
          2 months ago

          Do not worry, for they have fallen like many of our siblings; yet they are in a better place than some, like windows users.

          • aberrate_junior_beatnik@midwest.social
            link
            fedilink
            English
            arrow-up
            11
            arrow-down
            3
            ·
            2 months ago

            You’ve got it backwards. Of the two, Windows is closer to the open source ethos. Apple is a total control freak. Obviously both are bad, though.

            • 30p87@feddit.de
              link
              fedilink
              arrow-up
              2
              ·
              2 months ago

              At least MacOS is more Unix-like. So yes, in nearly everything important to a Linux user except CLI-UX (Command line interface user experience, nice word lol) Mac is worse than Windows somewhat, but as I would see the CLI-UX as one of the most important things (in my workflow, which is based on Linux tho), Max would be better than Windows. But of course, both are trash.

      • crozilla@lemmy.world
        link
        fedilink
        arrow-up
        4
        ·
        2 months ago

        Weird. I’ve never seen that on my Macs. I always have to click on “About Firefox” to check for and download any updates so it only updates when I do that.

        • sugar_in_your_tea@sh.itjust.works
          link
          fedilink
          arrow-up
          3
          ·
          2 months ago

          There’s also the menu icon, which let’s you know there’s a new version and you should update.

          I’ve never had Firefox update without my consent on macOS or Linux.

  • oscardejarjayes [comrade/them]@hexbear.net
    link
    fedilink
    English
    arrow-up
    10
    arrow-down
    1
    ·
    2 months ago

    I’ve never had any issues with tabs not restoring (I have 6729 tabs currently open, on the newest FF release, updated many times). What do you mean by “never completely capable of restoring my tabs”?

    • sugar_in_your_tea@sh.itjust.works
      link
      fedilink
      arrow-up
      4
      ·
      2 months ago

      I’m guessing they mean that state on the page is lost. Because that absolutely happens. I’ve never lost a tab and I usually have dozens if not hundreds of tabs open.

    • lilja@lemmy.mlOP
      link
      fedilink
      arrow-up
      2
      ·
      2 months ago

      I may have misworded it a bit. The tabs themselves get restored, but the state of the tabs (being logged in to a site, for example) isn’t always retained. In all fairness this is perhaps due to my privacy settings, but I’d prefer it if Firefox didn’t force me to restart.

  • Dark Arc@social.packetloss.gg
    link
    fedilink
    English
    arrow-up
    6
    arrow-down
    1
    ·
    edit-2
    2 months ago

    A different angle of attack might be … why isn’t it capable of restoring your tabs and is that fixable?

    Particularly relevant since this seems to be IT enforced updates.

      • Dark Arc@social.packetloss.gg
        link
        fedilink
        English
        arrow-up
        2
        ·
        edit-2
        2 months ago

        Did you read what OP wrote?

        I don’t know why two of you are replying to me saying “but it restores my tabs?”

        I’m asking OP "what’s going on that it doesn’t restore your tabs?’

  • hexagonwin@lemmy.sdf.org
    link
    fedilink
    arrow-up
    1
    ·
    2 months ago

    I’m looking for a soultion as well, since I use always private mode my tabs aren’t even restored after the restart and I get to lose all my tabs lol.

  • RenardDesMers@lemmy.ml
    link
    fedilink
    arrow-up
    3
    arrow-down
    3
    ·
    edit-2
    2 months ago

    I have the same issue but I feel the main problem is not this page but the fact that the tabs are lost. I’ve been using FF for so long and I keep losing tabs on updates. It’s really frustrating.

    • thingsiplay@beehaw.org
      link
      fedilink
      arrow-up
      1
      ·
      2 months ago

      You can enable saving the tabs when closing Firefox. I use Firefox like this since a decade or so. Open Settings > General > Startup and check option “Open previous windows and tabs” (its the first top most option on that page).

      You can also open the Menu > History > “Recently Closed Windows” and probably open the last window this way? I don’t know if this works after an update. But in the History menu could also be an option “Restore Previous Session”, when a session is available (maybe after an update??).

      Honestly, I don’t know why Firefox does not ask to reload tabs, after restart of an update. I think it’s an oversight.

      • RenardDesMers@lemmy.ml
        link
        fedilink
        arrow-up
        2
        ·
        2 months ago

        You can enable saving the tabs when closing Firefox.

        It is on and has been for years but I still lose all my tabs regularly.

        Is it because of Sync? Container Tabs? I don’t know

        If I’m not too mad next time, I will try to find out why I lose them but my instinct is to reopen right away the tabs that I need the most.

        • thingsiplay@beehaw.org
          link
          fedilink
          arrow-up
          1
          ·
          2 months ago

          I see. I am using Firefox like this for years and it works for me and I thought it would for everyone else by just enabling the option.

          As said, you could also look into the History menu to restore last session or closed window. And if all of this does not work for you, either look into an alternative plugin (should be the last option in my opinion) or simply save all open tabs in a temporary bookmarks folder before restart / update. Such a manual solution is always ugly, but if nothing else helps…

  • MehBlah@lemmy.world
    link
    fedilink
    arrow-up
    4
    arrow-down
    10
    ·
    edit-2
    2 months ago

    When I finally got tired of them crashing my browser at random times I took the time to stop them.
    You can change the addresses that it uses to check for updates in the about:config. To be sure though I put all of those addresses and IP’s in the hosts file to make sure there could be no contact. Now my firefox updates when I update my machine. Some of them may not be mozilla specific but all of them are blocked by me.

    I got this list by using a squid proxy on a VM to log all addresses firefox connected to and watching the logs as firefox ran with no sites loaded over a two week period.

    You can use the list below to search for keys in the about:config to change. Or you can just put these in your hosts file.

    This is my list

    127.0.0.1 safebrowsing.googleapis.com

    127.0.0.1 push.services.mozilla.com

    127.0.0.1 incoming.telemetry.mozilla.org

    127.0.0.1 detectportal.firefox.com

    127.0.0.1 img-getpocket.cdn.mozilla.net

    127.0.0.1 region1.google-analytics.com

    127.0.0.1 contile.services.mozilla.com

    127.0.0.1 mozilla.cloudflare-dns.com

    127.0.0.1 contile.services.mozilla.com

    127.0.0.1 versioncheck-bg.addons.mozilla.org

    127.0.0.1 content-signature-2.cdn.mozilla.net

    127.0.0.1 helper1.dap.cloudflareresearch.com

    127.0.0.1 dap-02.api.divviup.org

    127.0.0.1 shavar.services.mozilla.com

    127.0.0.1 aus5.mozilla.org

    127.0.0.1 versioncheck.addons.mozilla.org

    127.0.0.1 firefox.settings.services.mozilla.com

      • MehBlah@lemmy.world
        link
        fedilink
        arrow-up
        1
        arrow-down
        4
        ·
        2 months ago

        Yeah I think so but I didn’t care. I blocked them all since I don’t have a portal at my house. The point was to block their access to my machine. My trust is at all time low for most of these companies.